Unable to get Keevio to work

I have been trying to get support from our UK provider for assistance with Keevio, Can anyone shed any light on why I can’t get Keevio to work.

They Said (with the bullet points, my reply with the -)
You can use the softphone inbuilt in Keevio by following these steps to set it up:

• Force pabx to use https internally (global settings) (update firewall settings if needed for connection to pabx)

  • “Force HTTPS web access false / off” this is on.

• Enable keevio (Global settings)

  • This is disabled or random users get licences which I can’t change, unless I go through all 200+ users to disable this setting per user profile.

• Apply keevio phone to user (pabx user settings)

  • I have done this on a test user and I am now the only user with a keevio licence.
  • keevio phone device count is 2 of 10 device limit.

• Log on as the user via chrome and allow/select audio/mic use.

  • It doesn’t work.- No Keevio Access!

I have scanned the PABX with nmap internally and these are the ports listening.

Scanning phone ( [1000 ports]
Discovered open port 80/tcp on
Discovered open port 443/tcp on
Discovered open port 21/tcp on
Discovered open port 22/tcp on
Discovered open port 1443/tcp on
Discovered open port 5222/tcp on
Discovered open port 389/tcp on
Discovered open port 84/tcp on
Discovered open port 5269/tcp on
Discovered open port 5061/tcp on
Discovered open port 82/tcp on
Discovered open port 8089/tcp on

What else do i need to do??


It does look like you have configured everything right, but without any info on the PBX, domain name, software version, and config details for the user you are trying to setup it is very difficult to diagnose what hasn’t been enabled and we wouldn’t recommend you send these on a public forum.
Your best course of action would be to go back to your reseller and ask them to have one of their trained engineers check your config to ensure the user has been setup properly. They can then raise a ticket with us and give full details if they need any help.

Hi Rob,

Thanks for replying. It appears that I was using a system administrator account for testing and this doesn’t have all the user level features, once a super user was created on the platform that had user and administrator rights (which I now belong to) it worked.

Just a thank you for getting back!

Good luck with the platform.

Kind Regards